在MacOs安装pip 及各种问题解决
本文最后更新于 938 天前,其中的信息可能已经有所发展或是发生改变。

安装方法

在使用brew安装的时候出现未找到pip,然后发现是因为brew默认在执行brew install python的时候会自带pip??不太懂。但是pip又提示command not found。没办法只能用下面语句安装

sudo easy_install pip

成功安装,这时我们执行

pip -V

查看版本,发现竟然TMD安装到了系统的2.7版本py里,这不是我想要的结果

因为我开发是用python3.7(可以参考我的另一篇博文https://blog.zixutech.cn/archives/106 来查看如何在macos上安装双版本py)

所以pip必须为3.7服务,这样一来默认的指令 pip install xxx 就不能用了。

有两种方法可以为3.7版本装包

方法1

首先查看py3.7的包文件夹路径

终端以此执行

$ python3
>>> import sys
>>> print(sys.path)

得到如下结果

在MacOs安装pip 及各种问题解决插图

复制最后一个路径,我的是

/usr/local/lib/python3.7/site-packages

然后就可以开始执行安装指令了

[/shell]pip install -t /usr/local/lib/python3.7/site-packages/ 包名[/shell]

然后你的包就会安装在-t后面指定的位置了。

 

方法2

由于方法1比较复杂,这里推荐方法2

直接终端执行

python3 -m pip install 包名

也是可以顺利安装的。

总结

至此,pip及未来的包安装都弄好了。略略略

 

 



本站全部博文采用知识共享署名-非商业性使用 4.0 国际许可协议进行许可。

本文永久地址:https://www.zixutech.cn/archives/112
本文作者:紫旭
暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇